Forums


Textures losing quality?

Ask technical support questions about other topics

Textures losing quality?

Postby Koshari Mahana » Wed Feb 14, 2018 4:48 am

I have noticed over the years (it even did it once or twice in SL) that servers sometimes "forget" a texture, it's still there but it becomes strangely pixelated. Why does this happen and is there anything that can be done short of re-uploading and re-texturing? It doesn't happen often but it happens on all grids and all viewers now and then (although not at the same time with the same texture).
Four Winds Store on Kitely Market
https://www.kitely.com/market?store=9230634

Image
User avatar
Koshari Mahana
 
Posts: 56
Joined: Fri Feb 06, 2015 8:14 am
Has liked: 15 times
Been liked: 44 times

Re: Textures losing quality?

Postby Ilan Tochner » Wed Feb 14, 2018 9:27 am

Hi Koshari,

Texture data on servers doesn't degrade but your viewer sometimes caches a texture before it has successfully completed downloading. This can result in it appearing at a lower level of detail. The thing to do in such cases is to log into the grid, clear your viewer's cache and restart the viewer.
User avatar
Ilan Tochner
 
Posts: 4395
Joined: Sun Dec 23, 2012 8:44 am
Has liked: 2080 times
Been liked: 2318 times

Re: Textures losing quality?

Postby Koshari Mahana » Thu Feb 15, 2018 3:42 am

Thanks Ilan,

I did try that and for some textures it works but for others it doesn't.

The Kitely UUID is f8794632-16a6-4b06-8ecc-cfad498dd035

I did an experiment using both of my avatars (Kitely and GCG) and with both viewers (Firestorm and Alchemy) and on both grids (Kitely and GCG). I cleared the cache for both viewers and for both avatars. I also tested it with a completely different upload of the same item to GCG (which I know is unrelated but I did the test anyway). I also took a screenshot of a similar but different texture from the same building which has not failed and is the same as it always was, just for visual comparison.

Please see experiment screenshots:
https://docs.google.com/document/d/1udStQQ5AmGxOPhEBYq0EISKba10LFkOU1BErphWFGDQ/edit

The texture that failed is failed for both Kitely and GCG avatars on Kitely Grid and when I share it to my other avatar on the GCG grid. It’s also failed no matter which viewer is used, even after the cache is cleared in both viewers and for both avatars inventory. The same building was uploaded separately to GCG and the texture is fine, it's a completely different texture asset but I’m putting it here just for comparison.

Sometimes the various texture fails are on GCG or InWorldz or SL but not on Kitely or the others, it’s not a particular grid problem because from time to time it happens on all of them. So it seems to be server or grid memory rather than avatar inventory or viewer memory. It’s happened for years on different grids, different textures, different owners, different viewers etc… I’m just using this particular texture and instance as an example.

I do agree that sometimes it is avatar inventory or viewer memory and can be fixed by clearing cache, but sometimes it appears to be failed on the server itself. I’m only curious about it because when it does happen I have to upload a new texture, retexture the build, rebox the build and then redistribute it to those who own it. It would be nice if this didn’t happen but I suppose there is no way to stop it from happening.
Four Winds Store on Kitely Market
https://www.kitely.com/market?store=9230634

Image
User avatar
Koshari Mahana
 
Posts: 56
Joined: Fri Feb 06, 2015 8:14 am
Has liked: 15 times
Been liked: 44 times

Re: Textures losing quality?

Postby Ilan Tochner » Thu Feb 15, 2018 6:57 am

Hi Koshari,

Please send me the texture inworld.
User avatar
Ilan Tochner
 
Posts: 4395
Joined: Sun Dec 23, 2012 8:44 am
Has liked: 2080 times
Been liked: 2318 times

Re: Textures losing quality?

Postby Koshari Mahana » Thu Feb 15, 2018 7:31 am

Sent. Thanks for having a look.

There is no hurry on this at all and it's actually more of a curiosity, I don't know if there is any fix for it but it happens with different textures on nearly all grids, not often but it does happen. It seems to happen most after a grid has done an update, that's one reason why I believe it's server related.

If a texture has failed (when it isn't cache related) it looks the same for every avatar seeing it regardless of the viewer. That's why I tested with both avatars after clearing both caches and tested with both viewers after those caches were cleared too.

Again, no hurry, it's just a mystery, that's all.
Four Winds Store on Kitely Market
https://www.kitely.com/market?store=9230634

Image
User avatar
Koshari Mahana
 
Posts: 56
Joined: Fri Feb 06, 2015 8:14 am
Has liked: 15 times
Been liked: 44 times

Re: Textures losing quality?

Postby Chris Namaste » Thu Feb 15, 2018 11:50 am

yes, its nice u put this here since i have xactly same experience as u.
it mite be a bug somewhere (i really donno) its what most pple used to say who fixed it.
also textures taht go blank (im soo grateful that this never happend in kitely) that is worse nightmare.
not only for your creation that breaks (its why my inventory 'grew' so much since ive experienced such things since i learned 'i must keep all textures with the product'.
-also to keep the texture in inventory together with the creation 'to find the texture back on pc' when it breaks --) to have the orignal name of the texture.
so ican find them back in millions of them on pc.
as much & often as i can i box them all up to make invent smaller.
but customers really 'cant accept' that.
thx for topic koshari & thx for great help ilan :)
Chris Namaste (inworld i use voice - not chat nor im)
Chris CreationZ url kitely market : https://www.kitely.com/market?store=914 ... &sort=date
User avatar
Chris Namaste
 
Posts: 66
Joined: Wed Jan 27, 2016 6:55 pm
Has liked: 185 times
Been liked: 39 times


Return to Other Support

Who is online

Users browsing this forum: No registered users and 4 guests

cron