Restrict sound to parcel not working?

Ask technical support questions about other topics
Post Reply
User avatar
Iain McCracken
Posts: 22
Joined: Thu Feb 21, 2013 6:35 pm
Has thanked: 27 times
Been thanked: 6 times

Restrict sound to parcel not working?

Post by Iain McCracken »

I've just discovered that the "Restrict gesture and object sounds to this parcel" checkbox is not working as expected. It does the NOT of what I expect, turning off all sounds from this parcel in this parcel, while still transmitting sounds from this parcel into all other parcels.

This is a problem as I have a performance venue in a parcel next to one where there are some noisy exhibits. I wanted to restrict the noise to its own parcel, but I can't do that. The check box seems to disable all sound in this parcel, which is not what I want. I want the check box to do what it says, which is also what it does in SL.

Help!
User avatar
Ilan Tochner
Posts: 5853
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3709 times
Been thanked: 3830 times
Contact:

Re: Restrict sound to parcel not working?

Post by Ilan Tochner »

Hi Iain,

Is this in a single region world, in a multi-region one or in a world set as an Advanced Megaregion?
User avatar
Iain McCracken
Posts: 22
Joined: Thu Feb 21, 2013 6:35 pm
Has thanked: 27 times
Been thanked: 6 times

Re: Restrict sound to parcel not working?

Post by Iain McCracken »

Hi Ilan

It's a 512x512 advanced megaregion world.

Iain
User avatar
Ilan Tochner
Posts: 5853
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3709 times
Been thanked: 3830 times
Contact:

Re: Restrict sound to parcel not working?

Post by Ilan Tochner »

Please try turning off Advanced Megaregion mode and see if the problem remains.
User avatar
Iain McCracken
Posts: 22
Joined: Thu Feb 21, 2013 6:35 pm
Has thanked: 27 times
Been thanked: 6 times

Re: Restrict sound to parcel not working?

Post by Iain McCracken »

Hi Ilan

Turning off advanced megaregions changed the problem. Now, checking "restrict sound to this parcel" does nothing in the parcel the sound is coming from -- sound continues in that parcel, and in neighboring parcels.

Checking "restrict sound to this parcel" turns off sound from other parcels, but does not stop sound from leaving this parcel. Still not what I was expecting.

When I turned advanced megaregion back on, it broke the sim. Sim FPS went down to 12-25fps and many objects appear to have stopped working. I'm currently scrambling around trying to figure out why the physics engine is chewing CPU (turning physics off returned sim fps to 54, but you can't walk or fly).

I'm a little frazzled right now, not having realized that changing the advanced megaregions flag would have broken physics and scripts. Ada's spent a lot of time on this region.

Iain
User avatar
Ilan Tochner
Posts: 5853
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3709 times
Been thanked: 3830 times
Contact:

Re: Restrict sound to parcel not working?

Post by Ilan Tochner »

To update those following this thread, the high CPU was caused by two hollow non-phantom prims and one Physical object.
Graham Mills
Posts: 1090
Joined: Sun Dec 23, 2012 2:26 pm
Has thanked: 746 times
Been thanked: 860 times

Re: Restrict sound to parcel not working?

Post by Graham Mills »

Which physics engine?
Ilan Tochner wrote:To update those following this thread, the high CPU was caused by two hollow non-phantom prims and one Physical object.
User avatar
Ilan Tochner
Posts: 5853
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3709 times
Been thanked: 3830 times
Contact:

Re: Restrict sound to parcel not working?

Post by Ilan Tochner »

Hi Graham,

That world is currently set to use BulletSim Physics.
Post Reply