Page 5 of 13

llGiveInventoryList failing

Posted: Tue Feb 18, 2020 8:42 pm
by Kayaker Magic
In SL, the llGiveInventoryList function only works to avatars that are “nearby”. In OpenSim since version, llGiveInventoryList has become much more useful in vending machines because it can deliver to an avatar that is not even logged on. They may not get notification, but they find the new folder in inventory when next they log on. If they are logged on at delivery time, they get the new folder, a notification dialog and the option to accept or trash it.
HOWEVER, in Kitely under OpenSim, llGiveInventoryList fails with an ugly red debug message if you try to deliver to an avatar who is not nearby. It works fine if the avatar is logged on and in the same region, I haven’t tried all combinations.
To reproduce, put this script in a prim and also put an object “give”. Click on the prim to deliver the object. If the avatar is not in-world you will get an ANGRY RED DEBUG MESSAGE. I have this delivering to Crashtest Crystal, you can change it to a different avatar who is nearby and see it work, or change it to other avatars you know.

Code: Select all

//test llGiveInventoryList.
//  Note: Requires an object in memory to deliver.
// Delivers to a folder with same name as object
    touch_start(integer num)
        key av = osAvatarName2Key("Crashtest","Crystal");
        string fold = llGetInventoryName(INVENTORY_OBJECT,0);
        list prodstuf=[fold];
        llOwnerSay("Give Inventory List:\n"+(string)av+"\n"+fold+"\n"+llList2CSV(prodstuf));
My PayPal vendor tests for version 0.9 and above, calls llGiveInventoryList in those cases then crashes and burns.

Re: We've updated Kitely to OpenSim

Posted: Tue Feb 18, 2020 10:17 pm
by Ilan Tochner
Hi Kayaker,

What is the exact debug message you get?

The behavior you described where a script can just push items into people's inventory while they are offline and without them being asked to confirm accepting those items seems like a big security problem. It doesn't sound like a feature that we should duplicate. I can think of quite a lot of ways that that could be abused to grief people.

Re: We've updated Kitely to OpenSim

Posted: Tue Feb 18, 2020 11:09 pm
by Graham Mills
Chic Aeon wrote:
Tue Feb 18, 2020 8:20 pm
Ilan Tochner wrote:
Wed Feb 12, 2020 9:29 pm
Hi Graham,

What version of Firestorm and what do you mean by temporary derendering of objects? (what are the exact steps you're using to do that?)

Replying to this issue since the OP did not. I tested this on the sandbox using DERENDER rather then DERENDER AND BLACKLIST (assuming that is what the OP was referring to). It is still derendered after all the time I spent with the report on the uploader.
I am using the advised version of Firestorm -- not the new BOM version which they advised NOT to use.

Firestorm 6.0.2 (56680) Feb 9 2019 10:23:10 (64bit) (Firestorm-Releasex64) with OpenSimulator support
Release Notes

So steps would be right click the object and choose derender.
If you check back, you'll find I did respond albeit with not quite the level of detail you provide.

Re: We've updated Kitely to OpenSim

Posted: Wed Feb 19, 2020 1:54 am
by Kayaker Magic
The error you get is one of those stupid run-on errors that only C# programmers who are intimately familiar with the OpenSim sources has the slightest chance of figuring out:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object
at OpenSim.Region.Framework.Scenes.Scene.MoveTaskInventoryItems (OpenMetaverse.UUID destID, System.String category, OpenSim.Region.Framework.Scenes.SceneObjectPart host, System.Collections.Generic.List`1[T] items) [0x000bf] in <a400754dba7a41c2906ac44901893c0f>:0
at OpenSim.Region.ScriptEngine.Shared.Api.LSL_Api.llGiveInventoryList (OpenSim.Region.ScriptEngine.Shared.LSL_Types+LSLString destination, OpenSim.Region.ScriptEngine.Shared.LSL_Types+LSLString category, OpenSim.Region.ScriptEngine.Shared.LSL_Types+list inventory) [0x0009b] in <1a3b0e7396e947cc9a274ab6a23b8629>:0
at OpenSim.Region.ScriptEngine.Shared.ScriptBase.ScriptBaseClass.llGiveInventoryList (OpenSim.Region.ScriptEngine.Shared.LSL_Types+LSLString destination, OpenSim.Region.ScriptEngine.Shared.LSL_Types+LSLString category, Op
I ran this on one of my own worlds, it will not work on the sandbox! If you run it there you will get an OSSL error because osAvatarName2Key can only be run by estate managers and owners. You could set the av key to a known UUID, for example Crashtes Crystal's UUID is 3719b421-03f3-47d9-8f2d-824137a266d7 and you can replace the call to osAvatarName2Key with that constant and then you can run it in the sandbox and you will get the Exception error above.

Re: We've updated Kitely to OpenSim

Posted: Wed Feb 19, 2020 4:46 am
by Zed deTremont
Chic Aeon wrote:
Tue Feb 18, 2020 8:15 pm
Mesh uploader is VERY CONFUSED.

Varying results with same model and same choices in the upload window.
Agree with you that it's not accurate and something has changed when uploading meshes via firestorm after the update. On the other hand, it never gave some accurate details, now you get some weird number, before it just indicated 0.
As you indicated when the mesh is rezzed inworld it's just as before 1 mesh = 1 prim so perhaps, since both where wrong perhaps we better put it aside and neglect it. Testing for Li is just not possible in OS in general which has its good and bad points.

Re: We've updated Kitely to OpenSim

Posted: Wed Feb 19, 2020 6:42 am
by Ilan Tochner
We fixed the issue where some new Kitely Market listings displayed "missing material" errors for no apparent reason. If you listed a product between the time we updated to OpenSim and the time I posted this comment and you got this error then ply remove the Items from your listing and add them back again.

Re: We've updated Kitely to OpenSim

Posted: Wed Feb 19, 2020 1:04 pm
by Sunny Kirsten
I am having issues granting access to new users of the parcel. The 'add' button is greyed out. Is this an issue with the upgrade? I posted to general forum and another user has the same issue.

Re: We've updated Kitely to OpenSim

Posted: Thu Feb 20, 2020 2:12 pm
by Ilan Tochner
Hi Sunny,

Please see: viewtopic.php?f=6&p=26991#p26998

Re: We've updated Kitely to OpenSim

Posted: Thu Feb 20, 2020 6:01 pm
by Freda Frostbite
I am having a lot of trouble with LMs on login. My home is set to the dressing room of the Belles' Barn on Belle Terre. Yet when I log in to home, I land elsewhere, near center of the world, outside, by a river. Then, once inworld, I click the home button and it takes me there.

Also-- sometimes when using teleporters I created, I land not in the selected destinations but in the water at SW corner of the sim. This is not a consistent issue, but has happened to some guests as well as to me. It has also happened when people use LMS to teleport to my world from their own or from the HG. It's not great to have people land in the wrong places when they come in for events. Belle Terre is a big region and I can't watch radar the whole time I am running an event.

Re: We've updated Kitely to OpenSim

Posted: Thu Feb 20, 2020 6:53 pm
by Ilan Tochner
Hi Freda,

What is Teleport Routing set to in your landing point's parcel?

Note that parcels that have Teleport Routing set to Blocked will move people who try to teleport to those parcels to the parcel boarder.