llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Creating scripts
Post Reply
User avatar
Kayaker Magic
Posts: 338
Joined: Sun Dec 01, 2013 8:40 am
Has thanked: 49 times
Been thanked: 354 times

llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Post by Kayaker Magic » Tue Dec 31, 2013 7:54 am

If you call llSetRegionPos with a co-ordinate that is larger than 256 in x or y, it just refuses to do anything and leaves the prim where it is.
I guess I'll have to go back to using warpPos again.

Here is a script to demonstrate the problem.
Put this in a prim. If the prim is located inside 0 to 256 on both axes it will march away. When it gets to the 256 border, it will stop.
Drag it back with the edit dialog, it will move until it hits the 256 border at the edge of the universe again.
If it starts outside that range, or if you drag it there, it will just sit where you put it and not move at all.

Code: Select all

default
{
    state_entry()
    {
        llSetTimerEvent(1);
    }
    timer()
    {
        llSetRegionPos(llGetPos()+<1,1,0>);
    }
}
User avatar
Deuce Halsey
Posts: 322
Joined: Mon Oct 14, 2013 9:30 pm
Has thanked: 391 times
Been thanked: 260 times

Re: llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Post by Deuce Halsey » Tue Dec 31, 2013 8:44 am

I confirmed your results in my 4-region megaregion world. The script works fine in the Southwest (Home) region. When it gets to the boundary with another region it stops and sits.
I also tried rezzing the object in the other 3 regions of my world - it just sat there.
Deuce Halsey
Just4yucks in Kitely Marketplace
http://www.kitely.com/market?store=2704782
User avatar
Ilan Tochner
Posts: 4945
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2693 times
Been thanked: 2698 times
Contact:

Re: llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Post by Ilan Tochner » Tue Dec 31, 2013 8:52 am

We'll look into this after tomorrow's update.
These users thanked the author Ilan Tochner for the post:
Dundridge Dreadlow
User avatar
Brayla Sana
Posts: 67
Joined: Wed Mar 27, 2013 7:09 pm
Has thanked: 16 times
Been thanked: 113 times

Re: llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Post by Brayla Sana » Sun Jan 19, 2014 5:30 am

I saw this and I wanted to mention that Firestorm's cut and paste feature also fails in the same way. It works in the sw home region only.
Dadiella's for Fashion and Brayla Sana Gallery for Building!
User avatar
Oren Hurvitz
Posts: 303
Joined: Sun Dec 23, 2012 8:42 am
Has thanked: 9 times
Been thanked: 352 times
Contact:

Re: llSetRegionPos FAILS TO WORK IN MEGA REGIONS!

Post by Oren Hurvitz » Wed Jan 22, 2014 11:15 am

We've fixed many scripting functions to work in Advanced Megaregions, including llSetRegionPos(). See http://www.kitely.com/virtual-world-new ... g-physics/.
These users thanked the author Oren Hurvitz for the post (total 3):
Constance PeregrineKeith SelmesJack Spade
Post Reply