Sounds and About Land>Sound>restrict sound to this parcel

Creating sounds and music
Post Reply
Ohn Lang
Posts: 142
Joined: Sun Dec 23, 2012 5:11 pm
Has thanked: 38 times
Been thanked: 66 times

Sounds and About Land>Sound>restrict sound to this parcel

Post by Ohn Lang »

I just discovered something. I don't know if it is a glitch in my particular world, or if it is a general OS bug.

I have an object scripted to play a sound on collision. For the life of me I couldn't hear the sound, even after turning up every sound option in my viewer. As a last ditch effort, I opened the About Land dialog and looked at the SOUND tab. The first option below the Music URL field is Sound, with a check box and description "Restrict gesture and object sounds to this parcel." I have a habit of checking this box to make sure that noisy neighbors in one parcel don't bother quiet ones in another parcel (not that i have neighbors anywhere, LOL).

I thought "what the hay" and unchecked the checkbox, and voila! I was getting splatted at very high volume. Yay!

But, that check box should not actually disable sound on the parcel, it should only restrict sound on that parcel to the parcel so that people in other parcels don't hear that parcel's sounds. (say THAT five times fast)

So, is this an OS bug, a Kitely specific issue, a conflict in my world settings or something (I don't see any region or world sound settings)?

Not a big deal, now that I know what the problem is. Just wondering.

Added: I discovered this while working in my "ohn's hideaway" world, which is a 4-region megaregion.
These users thanked the author Ohn Lang for the post:
Xxaxx Constantine
User avatar
Ilan Tochner
Posts: 5508
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3265 times
Been thanked: 3357 times
Contact:

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Ilan Tochner »

Hi Ohn,

Thank you for letting us know, we'll investigate this.
These users thanked the author Ilan Tochner for the post:
Ohn Lang
User avatar
Constance Peregrine
Posts: 2328
Joined: Sun Dec 23, 2012 11:35 am
Has thanked: 2766 times
Been thanked: 1428 times

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Constance Peregrine »

yes, this is an old os bug....sometimes you can correct it by tp'ing out and back or moving from one parcel to another and back if parceled. Best to uncheck the default.

I don't say this as someone who knows the code, but from doing many events and sounds-))

Similarly, this happens with some streams, depending upon where they come from, which is why I almost always use my vlc player for streams.

[however, I may not know what I am talking about, so disregard if needed-))]
These users thanked the author Constance Peregrine for the post (total 2):
Ohn LangAdagio Greenwood
Laissez faire et laissez passer, le monde va de lui même!
My little sounds store https://www.kitely.com/market?store=2040306

Ephemeral wanderer...
Ohn Lang
Posts: 142
Joined: Sun Dec 23, 2012 5:11 pm
Has thanked: 38 times
Been thanked: 66 times

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Ohn Lang »

Thanks Minethere :D That takes out some of the mystery!
User avatar
Constance Peregrine
Posts: 2328
Joined: Sun Dec 23, 2012 11:35 am
Has thanked: 2766 times
Been thanked: 1428 times

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Constance Peregrine »

Ohn Lang wrote:Thanks Minethere :D That takes out some of the mystery!
It does? cool!!!!!

I have just found this issue crop up very very often...and it is even different from grid to grid...which I tend to feel is due to the different grids fiddling with the os code in different ways.

Just as some grids have ims that go to emails well done, others have the ability to email back to IMs, some grids have notice attachments working, some do not. I find it difficult grid-hoping to remember which ones do what...lol

Some grids the sounds are hardly an issue at all, others it is always an issue. If all else fails, a clear cache usually fixes it-))
Laissez faire et laissez passer, le monde va de lui même!
My little sounds store https://www.kitely.com/market?store=2040306

Ephemeral wanderer...
User avatar
Ilan Tochner
Posts: 5508
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3265 times
Been thanked: 3357 times
Contact:

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Ilan Tochner »

Firestorm and other v3 viewers restrict playing sounds to General rated regions by default. You can change this setting in the General tab of your viewer Preferences if your account has a higher maturity rating.

However, it looks like OpenSim currently doesn't transfer the relevant user maturity rating to the viewer so you can't change this preference to anything other than General.

We'll be discussing this issue with other OpenSim developers to see whether we can fix that problem.

In the meantime, as Kitely has its own world-level maturity rating access controls which are separate from OpenSim's controls, you can work around this limitation by using the viewer tools to change the regions in your world to General maturity rating and use the Access tab of the Manage World dialog (in your Kitely account control panel) to set the world's true maturity rating. Doing so will only allow people who have sufficient user maturity rating to enter that world, but anyone who does enter it will be able to hear all the sounds that are played inside it.
These users thanked the author Ilan Tochner for the post (total 2):
Adagio GreenwoodSelby Evans
User avatar
Selby Evans
Posts: 591
Joined: Wed Sep 04, 2013 6:00 pm
Has thanked: 1631 times
Been thanked: 751 times

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Selby Evans »

We seem to have run into this problem (sounds not playing from scripts) on Cookie II in the WIP events. Is there any new info about it?
User avatar
Ilan Tochner
Posts: 5508
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3265 times
Been thanked: 3357 times
Contact:

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Ilan Tochner »

Hi Selby,

Did you follow my advise about setting your regions to General using the viewer tools?
User avatar
Selby Evans
Posts: 591
Joined: Wed Sep 04, 2013 6:00 pm
Has thanked: 1631 times
Been thanked: 751 times

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Selby Evans »

Ilan Tochner wrote:Hi Selby,

Did you follow my advise about setting your regions to General using the viewer tools?
Yes I did. So far I am not hearing sounds from the applause gesture, but I will get some other people to come by and test with other sounds. Thanks for the quick response. I take it the bug still exists.
User avatar
Ilan Tochner
Posts: 5508
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 3265 times
Been thanked: 3357 times
Contact:

Re: Sounds and About Land>Sound>restrict sound to this parce

Post by Ilan Tochner »

As far as I know.
Post Reply