I Don't Even Know What to Call This

Discussion and support for the Kitely Market
Post Reply
User avatar
Luna Lunaria
Posts: 74
Joined: Thu Mar 16, 2017 1:02 am
Has thanked: 33 times
Been thanked: 118 times

I Don't Even Know What to Call This

Post by Luna Lunaria »

After completely retexturing a club build just to make the Market accept it, I retextured the separate bar I made for it. Did a trial upload and got a bunch of errors saying that the bar glasses, which are part of it, had a missing default material: 9fafe11a-b1e7-e7bc-91bd-5a3265231784 to be precise, which matches nothing I'm using with diffuse, normal, or specular maps. I was like, 'I know I retextured everything, but let's redo the glasses. Same result. I unlinked the glasses. I test uploaded a set of the glasses with no issue. I uploaded the bar without the glasses with no issue. I linked the glasses to the bar and uploaded the full bar, and lo and behold the missing material for the glasses were being flagged again. Just a miserable process trying to list anything on the market that I make on another grid. I would make the original on Kitely, but then it puts my old avatar name on the build when it goes out to the hypergrid- a name I changed almost 4 years ago, but that's a whole other can of worms.
User avatar
Luna Lunaria
Posts: 74
Joined: Thu Mar 16, 2017 1:02 am
Has thanked: 33 times
Been thanked: 118 times

Re: I Don't Even Know What to Call This

Post by Luna Lunaria »

So it appears the 'default missing material' is a topic of multiple posts here, and after reading through all the gobbledy-gook, about the only suggestion that made any sense whatsoever was that 'our slow asset server is incapable of keeping up with user changes in real time, so try uploading again the next day', or something to that effect. Tomorrow I will try again.
User avatar
Ilan Tochner
Posts: 6287
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 4535 times
Been thanked: 4294 times
Contact:

Re: I Don't Even Know What to Call This

Post by Ilan Tochner »

Hi Luna,

There is no issue with our asset server. I recommend you to read: https://www.kitely.com/virtual-world-ne ... -products/

And start reading the following thread from here: viewtopic.php?p=21684#p21684

Does your product use any scripts, dynamic textures, temp textures or particle systems?

What is the exact path in your Kitely avatar's inventory to this product?
These users thanked the author Ilan Tochner for the post:
Chris Namaste
User avatar
Luna Lunaria
Posts: 74
Joined: Thu Mar 16, 2017 1:02 am
Has thanked: 33 times
Been thanked: 118 times

Re: I Don't Even Know What to Call This

Post by Luna Lunaria »

Thanks for responding.

The inventory path is: *Personal Builds /**For Kitely Market / Venues / Victorian Club / Victorian Club Bar

No temp textures or particle scripts
The two scripts used are AVSitter for the bar stools, and a light controller script that turns on the lamps and under bar lights
Have no clue what a dynamic texture is and a google search didn't help

Thank you
Graham Mills
Posts: 1242
Joined: Sun Dec 23, 2012 2:26 pm
Has thanked: 995 times
Been thanked: 1056 times

Re: I Don't Even Know What to Call This

Post by Graham Mills »

Dynamic texture is an OSSL feature -- see under Prim drawing/Dynamic texture. Unlikely to be an issue here.

http://opensimulator.org/wiki/OSSL_Implemented
User avatar
Oren Hurvitz
Posts: 361
Joined: Sun Dec 23, 2012 8:42 am
Has thanked: 19 times
Been thanked: 499 times
Contact:

Re: I Don't Even Know What to Call This

Post by Oren Hurvitz »

Hi Luna,

I think I found how to fix the problem. I created a copy of the "Victorian Club Bar" object and rezzed it in one of my worlds. I checked, and at that point it had the problem you described, where some Material UUID's referred to missing materials. Then I started to fix this problem for the "Glass Set#3" objects (the small glasses). I clicked on every single copy of these glasses, and in the Texture tab I turned the option "Full Bright" off and back on. After I did this for all the glasses (whew!) I took the object back into my inventory. I checked, and the bad material was gone!

The reason this works is that Materials aren't regular assets like textures or meshes. They are fake assets that are created dynamically by the viewer whenever you change anything in the Texture tab. So by changing the "Full Bright" option off and back on I made the viewer regenerate the materials. When the viewer regenerated the materials it fixed the problem. I didn't have to change the actual textures; just changing this one checkbox was enough.

Please try this! After you've done this for all copies of "Glass Set#2" and "Glass Set#3", try to list the item again. Please let us know if you still see errors. (You will get errors if you miss even a single copy of the glasses... But hopefully fewer errors than before.)
These users thanked the author Oren Hurvitz for the post (total 5):
Ilan TochnerChris NamasteAda RadiusGraham MillsLuna Lunaria
User avatar
Luna Lunaria
Posts: 74
Joined: Thu Mar 16, 2017 1:02 am
Has thanked: 33 times
Been thanked: 118 times

Re: I Don't Even Know What to Call This

Post by Luna Lunaria »

Thanks Oren, I would never have thought to even try this. I ended up unlinking all the glassware and including it separately in the sales box with the Club and it all uploaded without issue. It was only when linked to the bar that it created the issue.
These users thanked the author Luna Lunaria for the post (total 2):
Ilan TochnerOren Hurvitz
Post Reply