Page 2 of 3

Re: Problem with Permissions

Posted: Thu Jan 07, 2021 3:21 pm
by Ilan Tochner
Hi Snoots,

IIRC changing an object's permission when its inside a rezzed box is different from changing the permissions of an object that is inside an object that is inside a rezzed box. The former is applied immediately and the later uses the Slam Bit and doesn't get applied until the object is rezzed. As our system uses the object's current permissions and not whatever the Slam bit may eventually apply, you changing object permissions while they were inside your delivery box (the egg) wouldn't have applied the changes until you've actually rezzed the item contained in that box that contain your notecard (the dragon).

Re: Problem with Permissions

Posted: Thu Jan 07, 2021 3:52 pm
by Ada Radius
Ya, but all that object nesting causes problems cuz perms is contagiously poisonous.
My current workflow, after much gnashing of tiny pointed teeth, is:

*system clothing, system skins, system hair, system eyes, universal layer, alpha layer, tats etc: check all the textures to make they are all full perm
rez out a box, put the system avatar stuff in the box, fix perms to what you want in the box, take back to inventory as a folder, delete box
*rez out all objects. check their textures, fix perms in the object perms and on the object
take back to inventory, delete the sim copies.
*Slide fixed objects into the folder. Name the folder the way you want it to look in the KM listing
*Add notecards, landmarks, scripts to the folder. These items are almost never the problem - the the perms in inventory are more stable than avatar clothing and body parts
*add the folder to KM listing. Check the perms there. Some stuff might still have to be fixed and re-uploaded.
Blame LL, viewer devs and OS devs, whine at Ilan and Oren some more
*Rinse, repeat

Remind oneself not to upload textures and mesh with restrictive perms - there are settings in Preferences to prevent that but gotta remember to check them when there's a viewer upgrade. Lately I've been experimenting with keeping everything full perm in inventory, restricting the perms in the KM upload folder, then delete that folder after the KM listing works. Workflow needs work, ya.

Re: Problem with Permissions

Posted: Thu Jan 07, 2021 11:28 pm
by Snoots Dwagon
Ada wrote:Ya, but all that object nesting causes problems cuz perms is contagiously poisonous.
Couldn't agree more. Often I wishes to kick some virtual logic-designer in da backside... but it would probably knock dem out.

These things cause issues with non-rezzable items. I don't know how many times over the years I've seen that slam bit concept ruin a build... even for the original creator. I've seen original creations turn no-perm (nomod, nocopy or notrans), and the creator scream because something flaked out behind the scenes and ruined his/her creation. Create something and have it turn notrans... and you better hope you took regular backups (which I do religiously... just because of this).

Ilan, I think either I'm not understanding something or there is a miscommunication somewhere. Let me detail:

The dwagon avatar inside each egg was rezzed and permed (every part), taken to inventory, then put inside the egg. So permissions were set as usual. This of course, does not include the notecard, which HAS to be permed either in-inventory or inside a box. There's no other option. (I usually perm notecards in inventory... which is a "no no" but I've never had it fail to have the desired end-result.)

The eggs themselves were nomod, but the items inside were mod. I put those 12 eggs inside the main egg and set the perms on the main egg to mod. I then took the main egg to inventory for listing on KM.

It showed up in Kitely Market as nomod. So I rezzed the main egg and changed the perms of the eggs inside to MOD, took that new main egg to inventory, deleted the old main egg and had KM point to the new main egg. The item registered as Mod on Kitely market (and I had changed the individual dwagon egg permissions while inside the main egg).

So I'm still not sure I understand why the inner eggs had to be changed to mod when the main egg was already set to mod. You've probably already explained it, but I'm not understanding. ;D

Re: Problem with Permissions

Posted: Fri Jan 08, 2021 12:01 am
by Ilan Tochner
Please try it without the egg, just inside folders as Ada explained. Get it to the point where you're getting the permissions you expect in the product listing then rezz the egg, give it the permissions you want and add the items into it. Once that's done take the egg into your inventory and add it into Kitely Market.

Re: Problem with Permissions

Posted: Fri Jan 08, 2021 1:19 am
by Snoots Dwagon
I already got it to work, same day I posted this forum. I've just been trying to understand what's going on behind the scenes that caused it to have the KM perms problems in the first place. : )

Item is on the market and working, so that's fine. The thing is... it didn't list with the perms I wanted it to have, which is the issue. Logically, I should have been able to perm the main egg Mod, the innner egg shells no mod, the avatars themselves mod, and then have been able to post the item as mod. Something prevented me from doing that, which was the issue. But as with similar things I figured out a work-around, and can do so in the future. Figuring out work-arounds is definitely not new to virtual worlds. :mrgreen:

Re: Problem with Permissions

Posted: Sat Jan 09, 2021 10:37 am
by Tess Juel
I have a related but slightly different question - not sure if I should have posted it as a separate thread.

I always include one or more copy/transfer no modify items in my listings. There's a group joiner nobody ever uses (so no group gifts for them! ;) ) and usually also a notecard or two with some info about the product and such.

Does this mean the listing will be listed as no modify even though the actual item for sale is?

Re: Problem with Permissions

Posted: Sat Jan 09, 2021 2:16 pm
by Ilan Tochner
Hi Tess,

If at least one of the included items is Modify then the product variation will be listed as Modify. Whereas if you want the listing to indicate Copy, Transfer or Export then ALL the included items need to be Copy, Transfer or Export (respectively).

Re: Problem with Permissions

Posted: Thu Jan 21, 2021 4:21 pm
by Ada Radius
The slambit errors are even worse than Snoots talked about. I spend hours yesterday trying to get a pair of mesh eyeballs, four variations in all, up at Kitely Marketplace yesterday, uploading via a folder, then individually. I tried:

rezzing them out inworld to verify perms then taking back to inventory
putting them in a box to force perms then taking back to inventory
wearing them to check perms and detaching
changing perms in inventory via properties

None of these methods worked reliably. The variation consists of changes to the environment color in the specular slot in the textures settings (cat eyes shine in the dark). The actual textures are fine and worked in other uploads. The perms for the eyeballs looked fine in inventory, looked fine in my slambit error fixing box, looked fine rezzed out, looked fine worn on my avatar, and still showed up in my KM products listing with the wrong perms. I have no idea what causes it and don't have a good workflow for fixing it.

Incredibly time consuming and frustrating.

Re: Problem with Permissions

Posted: Thu Jan 21, 2021 4:28 pm
by Ilan Tochner
Hi Ada,

Are the textures contained inside another object or are they applied to it?

If you give the item to an alt inworld does that alt see it with the permissions that you expected?

Re: Problem with Permissions

Posted: Thu Jan 21, 2021 6:01 pm
by Ada Radius
@Ilan: the textures (Bakes on Mesh, normal map, specular map) are in Inventory, same applied to all of the eyes.

I'll get myself an alt and try that.