Textures not staying on prims

Ask questions about creating worlds, using worlds, etc.
Don Smith
Posts: 34
Joined: Fri Jun 03, 2016 6:13 pm
Has thanked: 152 times
Been thanked: 41 times

Re: Textures not staying on prims

Post by Don Smith » Tue Oct 11, 2016 10:51 pm

I did what you asked me to do, the copies in world are still the same and when i rez a new copy from inventory its still the same. The pattern i saw from alchemy is now the same with firestorn, it probably was already this way and i didnt see it that way till i used alchemy. the fixed prims with correct textures on them still have the same problem if i attempt to change the texture. So i dont believe it is a difference in viewer as i am getting the same results with each now. < i will double check this on singularity in a few minutes and report back >
Don Smith
Posts: 34
Joined: Fri Jun 03, 2016 6:13 pm
Has thanked: 152 times
Been thanked: 41 times

Re: Textures not staying on prims

Post by Don Smith » Tue Oct 11, 2016 11:01 pm

Just did the same things in singularity, same results, if i change a texture it goes back to the previous texture. the ones that are fixed, still look fixed and rez fixed from inventory. So if all 3 viewers get the same results, what do we do next? The only other pertinent detail i have, is i seem to mostly experience problems like this on odd shaped or really big prims. the only texture problem i have on normal shapped/sized prims is when applying a texture to multiple prims at a time,< and sometimes single prims > it doesnt always stick, it shows its on there but when i press done it reverts to a previous texture on some of the prims, sometimes all of the prims, i wind up having to try and apply a texture multiple times to get it to actually take on the prims. Ozwell told he he has also experienced this problem from time to time. I am sure its not just me and him having these issues. Its extremely annoying when building.

Please advise.
User avatar
Ilan Tochner
Posts: 4979
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2759 times
Been thanked: 2743 times
Contact:

Re: Textures not staying on prims

Post by Ilan Tochner » Tue Oct 11, 2016 11:38 pm

If I'm not mistaken the viewer sends the instruction to update prims using UDP (an unreliable protocol that doesn't resend lost packers) instead of TCP, which means that messages can get lost between the viewer and the server due to network issues. The more changes need to be transferred between the viewer and the server the more likely you'll encounter some problem with them.

The way to work around that is to minimize the number of changes you make at any given point in time (to reduce the amount of update packets that need to be sent) or move to a location that is closer to the server you're connecting to (in ping time) so that less UDP packets will get lost along the way. One way to do the latter is to connect to your ISP via a wired connection instead of a wireless one. BTW, this is why you may encounter more issues when connecting to an OpenSim server remotely compared to when you connect to one that is running inside your home network.

Please note that we don't do any SL-derived viewer development. Had we been in the business of doing so, we would have replaced a great deal of the viewer/server messaging code, cache management code, the code used to communicate with the Vivox voice server, and quite a lot more that is the cause of many of the issues people report in our forums. I don't want it to sound like we're shrugging responsibility but there are quite a lot of issues with existing SL-derived viewers that we can't work around on the server side.
These users thanked the author Ilan Tochner for the post:
Selby Evans
Don Smith
Posts: 34
Joined: Fri Jun 03, 2016 6:13 pm
Has thanked: 152 times
Been thanked: 41 times

Re: Textures not staying on prims

Post by Don Smith » Wed Oct 12, 2016 12:03 am

Hi

I understand what you are saying. I have sent you a folder named " don smith texture problem kit" , it contains a full perm copy of the prim that is giving me problems. Please rez a copy and apply various textures to it, remember to press "done" so you can see it revert to a previous texture. This way , it might help you know more about what the problem might be and maybe some suggestions further on it. thanks.
User avatar
Ilan Tochner
Posts: 4979
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2759 times
Been thanked: 2743 times
Contact:

Re: Textures not staying on prims

Post by Ilan Tochner » Wed Oct 12, 2016 6:36 am

Thank you Don. I'll look at it the next time I go inworld.
User avatar
Giz Ihnen
Posts: 11
Joined: Fri Mar 04, 2016 9:24 pm
Has thanked: 8 times
Been thanked: 27 times

Re: Textures not staying on prims

Post by Giz Ihnen » Thu Oct 13, 2016 7:06 am

Just wanted to add... I have a similar problem. For me, I tortured a prim into a 4 petal flower, and when I try to texture one of the "odd" sides, no matter what texture I place on it, it reverts back to default wood.

I also found that it happens on other objects, that I did not create, that I try to modify with a different texture, the original texture is completely gone and reverts to default wood. This happens in every viewer I've tried, FS 4.7.7 & 4.7.9, Singularity 1.8.6 and Imprudence 1.3.2.

This ONLY happens to me when I try to texture an "odd" side of a tortured prim. Regular faces texture perfect, it's the extra ones you get when you start to twist it up that are giving me problems...

Maybe the added info will help track down the problem

You're not alone Don :D
These users thanked the author Giz Ihnen for the post (total 2):
Don SmithIlan Tochner
Don Smith
Posts: 34
Joined: Fri Jun 03, 2016 6:13 pm
Has thanked: 152 times
Been thanked: 41 times

Re: Textures not staying on prims

Post by Don Smith » Thu Oct 13, 2016 2:35 pm

Thank you Giz.

I have new information. I went to encoreescape grid < hosted by digiworldz > and gave a full perm copy of the prim in question to a friend, who rez'd it and had the same issues there. The surfaces of the prim in question is highly tortured, < oddly shaped, cut, twisted, hollowed, elongated ect > as Giz suggested in her reply. To make a tree ribbon, it began as a torus and is manipulated highly to the point that the part we see textured is actually the inside of a cut on the prim. I believe it has something to do with these odd shaped, huge , and otherwise tortured prims. It doesnt seem to matter where the person is in the world connecting, the viewer they use, or the grid servers in open sim they are connecting thru, the only consistent thing with this problem is the prims themselves being oddly tortured and shaped then textures applied.

I hope this helps narrow down the issue.
These users thanked the author Don Smith for the post (total 2):
Ilan TochnerDot Matrix
Post Reply