Scripts Not Running After Restart

Ask questions about creating worlds, using worlds, etc.
User avatar
Koshari Mahana
Posts: 129
Joined: Fri Feb 06, 2015 8:14 am
Has thanked: 51 times
Been thanked: 159 times
Contact:

Scripts Not Running After Restart

Post by Koshari Mahana » Wed May 22, 2019 9:03 pm

This doesn't seem to be a consistent problem, it's very random and unpredictable. I've heard from some of the residents of Coopersville that they have had script stop working. There is also a problem (again, seemingly arbitrary) with door scripts being switched to "not running" for no apparent reason. It's not happening often, maybe once a week and with different doors each time. I'm running bulletsim but I've heard from others that this happens with ODE too. Any thoughts?

Thanks!
Koshari
These users thanked the author Koshari Mahana for the post (total 2):
Ilan TochnerChris Namaste
User avatar
Ilan Tochner
Posts: 4944
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2691 times
Been thanked: 2697 times
Contact:

Re: Scripts Not Running After Restart

Post by Ilan Tochner » Wed May 22, 2019 9:19 pm

Hi Koshari,

It's good practice to ensure that your scripts handle region start events. Region restarts can happen on any grid so you have to ensure your scripts will know how to handle them.
User avatar
Koshari Mahana
Posts: 129
Joined: Fri Feb 06, 2015 8:14 am
Has thanked: 51 times
Been thanked: 159 times
Contact:

Re: Scripts Not Running After Restart

Post by Koshari Mahana » Wed May 22, 2019 10:49 pm

Hi Ilan, Thank you. The door scripts I'm using I've used for years in many different grids and I have them in the doors of most of the buildings and I've never experienced the scripts not running after restart before, nor has anyone ever reported to me that this has happened to them with my buildings. This is either a new problem or it's specific to Coopersville because it doesn't happen in Four Winds. Then a couple of others said it's happened to them elsewhere so I don't know what to think.
These users thanked the author Koshari Mahana for the post:
Chris Namaste
User avatar
Koshari Mahana
Posts: 129
Joined: Fri Feb 06, 2015 8:14 am
Has thanked: 51 times
Been thanked: 159 times
Contact:

Re: Scripts Not Running After Restart

Post by Koshari Mahana » Wed May 22, 2019 11:02 pm

Again, it's arbitrary, it is happening in different buildings each time yet it affects all of the scripts in the linked section even if they are different scripts. Like I said, it doesn't happen all the time, maybe once a week.
These users thanked the author Koshari Mahana for the post:
Chris Namaste
User avatar
Ilan Tochner
Posts: 4944
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2691 times
Been thanked: 2697 times
Contact:

Re: Scripts Not Running After Restart

Post by Ilan Tochner » Wed May 22, 2019 11:57 pm

Do the script throw any errors? How many scripts to you currently have running in Coopersville? (if you have many it's more likely that problems could occur)
User avatar
Koshari Mahana
Posts: 129
Joined: Fri Feb 06, 2015 8:14 am
Has thanked: 51 times
Been thanked: 159 times
Contact:

Re: Scripts Not Running After Restart

Post by Koshari Mahana » Thu May 23, 2019 3:00 am

No, the scripts that are stopping aren't showing errors. I don't know how many scripts there are in coopersville, how can I find that number?
These users thanked the author Koshari Mahana for the post:
Chris Namaste
User avatar
Ilan Tochner
Posts: 4944
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2691 times
Been thanked: 2697 times
Contact:

Re: Scripts Not Running After Restart

Post by Ilan Tochner » Thu May 23, 2019 4:48 am

In Firestorm you can open the Statistics Bar by pressing CTRL-Shift-1

You can view more information in the sections inside the Statistics Bar by clicking them (each click opens or closes the additional information section for the section that was clicked).
User avatar
Chris Namaste
Posts: 158
Joined: Wed Jan 27, 2016 6:55 pm
Has thanked: 514 times
Been thanked: 145 times

Re: Scripts Not Running After Restart

Post by Chris Namaste » Thu May 23, 2019 10:27 am

yes, i experience the same as koshari in her beautiful sim
its really,as she explains

exemple :
in other sim the sit script (simple scripts & used since long), works fine (in kitely)
in kitely merchant sandbox & some other sims they dont work (i have 10 y sl experience,- im not a scripter at all -,
i just 'know' when someth doesnt work for a reason we dont understand) :),
and its kinda, worrying,since im afraid if we build someth, it wont work everywhere & customers mite b upset
just want to help with this info
thanks:)
These users thanked the author Chris Namaste for the post:
Koshari Mahana
Chris Namaste (inworld i use notes & voice - i rarely chat nor im)
Chris CreationZ url kitely market : https://www.kitely.com/market?store=914 ... &sort=date
User avatar
Ilan Tochner
Posts: 4944
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2691 times
Been thanked: 2697 times
Contact:

Re: Scripts Not Running After Restart

Post by Ilan Tochner » Thu May 23, 2019 10:46 am

I just visited Coopersville and found issues that may explain why some scripts don't run consistently well in your world.

There are currently more than 3800 active scripts in your world and enough of them are doing resource-intensive operations when the world is started to drive up CPU usage enough that it's possible that some of their operations may time out during this high-CPU usage period.

I recommend you restart your world and look at the Top Scripts window to check which scripts may require investigation and possible optimization. See: https://kitely.atlassian.net/wiki/space ... erformance
These users thanked the author Ilan Tochner for the post (total 4):
Chris NamasteSelby EvansKoshari MahanaZed deTremont
User avatar
Koshari Mahana
Posts: 129
Joined: Fri Feb 06, 2015 8:14 am
Has thanked: 51 times
Been thanked: 159 times
Contact:

Re: Scripts Not Running After Restart

Post by Koshari Mahana » Thu May 23, 2019 3:32 pm

Thanks, I'll try that.
Post Reply