something is off in physics

Building using prims, sculpties and meshes. Texture creation techniques.
Post Reply
User avatar
Serendipity Seraph
Posts: 74
Joined: Sun Dec 30, 2012 9:57 am
Has thanked: 18 times
Been thanked: 25 times

something is off in physics

Post by Serendipity Seraph » Sun Aug 06, 2017 10:16 pm

On one of my worlds (Seren's World) something is odd about the physics. I created a large platform and flew over and landed. Sank into it. So I got off and made it physical and that worked except for it wiggling a bit. Turned off physical and it worked. Then I did a cut on the square to make it instead a half square triangle. To my surprise my avatar is at the height of the platform for the missing cut section as well as the part still there. This is very strange. Anyone seen such? No how to fix it? And yes I tried with two different viewers (Firestorm and Singularity). Same thing.
User avatar
Ilan Tochner
Posts: 4591
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2262 times
Been thanked: 2431 times
Contact:

Re: something is off in physics

Post by Ilan Tochner » Sun Aug 06, 2017 10:25 pm

Hi Serendipity,

First, I would highly advise against making a platform Physical when what you want is for it to be non-Phantom. Walking on Physical objects can create a LOT of server load, especially when multiple avatars are doing so.

Regarding the problem you encountered, is your world set to use the ODE of BulletSim physics engine? (you can check in the Advanced tab of that world's Manage World dialog).
Graham Mills
Posts: 979
Joined: Sun Dec 23, 2012 2:26 pm
Has thanked: 578 times
Been thanked: 735 times

Re: something is off in physics

Post by Graham Mills » Mon Aug 07, 2017 5:22 pm

Serendipity Seraph wrote:On one of my worlds (Seren's World) something is odd about the physics. I created a large platform and flew over and landed. Sank into it. So I got off and made it physical and that worked except for it wiggling a bit. Turned off physical and it worked. Then I did a cut on the square to make it instead a half square triangle. To my surprise my avatar is at the height of the platform for the missing cut section as well as the part still there. This is very strange. Anyone seen such? No how to fix it? And yes I tried with two different viewers (Firestorm and Singularity). Same thing.
I just tried this on a low prim (1260 prims) 2x2 world using ODE, 50x50x0.5m platform at 100m and everything worked as it should first time.

I then tried it on a 42K prim 3x3 world with the platform at 550m, again using ODE. I used tp2cam to move to it and had a similar physics glitch to the one you describe. The problem, however, was temporary and I was unable to replicate it by creating further platform prims from the build dialog or by shift-copy so I didn't/couldn't explore further. The original platform became able to support my avatar without further intervention.

Personally I'd be inclined to shrug and put it down to some form of latency but it would be interesting to have further detail of your experience and whether you could replicate it.

PS: I would add, however, that the physics glitch on the high prim world caused the avatar to fall through several platforms, not just the one recently created.
These users thanked the author Graham Mills for the post:
Ilan Tochner
Post Reply