osTeleportAgent fails on HG out of Kitely w/ pos>256

Ask technical support questions about other topics
Post Reply
User avatar
Kayaker Magic
Posts: 322
Joined: Sun Dec 01, 2013 8:40 am
Has thanked: 46 times
Been thanked: 335 times

osTeleportAgent fails on HG out of Kitely w/ pos>256

Post by Kayaker Magic » Fri Apr 20, 2018 8:56 pm

If I try to make a teleporter to take me to another grid on a touch, it sometimes works and sometimes does not.
I narrowed it down and discovered if you are teleporting from Kitely to another grid, to a location in a var region that is >256, then the teleport fails with this error message:
"Teleport failed. The region you tried to teleport to doesn't exist anymore".
If I HG TP from Kitely to another grid with a location that is less than 256,256 it works fine. (After the expected delay for the other region to load).
I tried a bunch of different combinations:
Teleport from Kitely to Kitely inside a Var region, location >256 WORKS FINE.
Teleport from Kitely to Kitely from one region to another var region, location >256 WORKS FINE.
Teleport from Kitely to another grid, location <256 WORKS FINE.
Teleport from Kitely to another grid, location>256 FAILS! Gets the error message above.

Here is a script that works fine if run from an OSGrid region, but fails in Kitely because of the landing point >256 in a var region:

Code: Select all

 
//Minimalist Teleporter
//
string Destination = "discoverygrid.net:8002:Pangaea";   // your target destination here
vector LandingPoint = <347,627,24>;     // the landing point for avatar to arrive at
vector LookAt = <0,1,0>;              //which way they land facing north=<0,1,0> east=<1,0,0> south=<-1,0,0> west=<0,-1,0>

default
{
    touch_start(integer num) 
    {
        osTeleportAgent(llDetectedKey(0), Destination, LandingPoint, LookAt);    
    }
}
These users thanked the author Kayaker Magic for the post:
Ilan Tochner
User avatar
Ilan Tochner
Posts: 4472
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2101 times
Been thanked: 2318 times
Contact:

Re: osTeleportAgent fails on HG out of Kitely w/ pos>256

Post by Ilan Tochner » Fri Apr 20, 2018 9:46 pm

Hi Kayaker,

Have you tried this from inside OSgrid to a high coordinate on a big Kitely world? From inside OSgrid to a high coordinate on a VarRegion on another non-Kitely grid?
User avatar
Kayaker Magic
Posts: 322
Joined: Sun Dec 01, 2013 8:40 am
Has thanked: 46 times
Been thanked: 335 times

Re: osTeleportAgent fails on HG out of Kitely w/ pos>256

Post by Kayaker Magic » Sat Apr 21, 2018 3:04 pm

Oh yeah, I forgot to mention:
Teleport from OSGrid to Discovery Grid, location >256 WORKS FINE. (Both regions running OpenSim 0.9.1 dev fairly recent builds)
it didn't occur to me to go the other way, so I tried that just now:
Teleport from OSGrid to Kitely, location >256 WORKS FINE.

The only combination that has not worked is teleporting from Kitely to another grid with a location >256.

For the case that I need it for now, I'm considering a relay: Jump from Kitely to a remote location <256. Then put a prim there that detects the avatar landing on it and TPs them to the place I really wanted to send them.
User avatar
Ilan Tochner
Posts: 4472
Joined: Sun Dec 23, 2012 8:44 am
Has thanked: 2101 times
Been thanked: 2318 times
Contact:

Re: osTeleportAgent fails on HG out of Kitely w/ pos>256

Post by Ilan Tochner » Sat Apr 21, 2018 4:30 pm

This may be due to changes in how different OpenSim versions implement this function. Please try repeating this test with a locally run standalone running OpenSim 0.8.2.1.
Post Reply